Game Requirements

From Old School RuneScape Wiki
Jump to: navigation, search

To be able to play Old School RuneScape, we recommend having the following:

Minimum System Requirements[edit | edit source]

  • CPU: Intel Pentium, Intel Celeron, Intel Core, Intel Mobile or AMD Mobile series/single and Dual core.
  • GPU: SiS, Matrox, Intel GMA series, Intel HD series, Via Chrome, GeForce 4, ATi Radeon 9000 Series
  • RAM: 1GB DDR

Recommended System Requirements[edit | edit source]

Windows[edit | edit source]

  • CPU: Intel i3+/AMD @ 2.4+ GHz
  • GPU: GeForce 400x, Intel HD 4x, AMD Radeon 7xxx +
  • RAM: 4GB

Mac[edit | edit source]

  • CPU: Intel i3+ @ 2.4+ GHz
  • GPU: AMD Radeon 7xxx +
  • RAM: 4GB

Mobile[edit | edit source]

  • Android Lollipop 5.0 or above
  • iOS 10.0 or later.

Software Requirements[edit | edit source]

Game Software[edit | edit source]

By downloading this software you agree to RuneScape's End User Licence Agreement.

There are several clients that can be used to play Old School RuneScape including the Java Client, Steam Client and Old School RuneScape Mobile.

Java[edit | edit source]

Java is required to run the Java Client, but the Windows Java Client includes it.

What hardware do I have?[edit | edit source]

Find out what what hardware your device has.

Input[edit | edit source]

  • Mouse
  • Keyboard

No longer supported[edit | edit source]

  1. The following operating systems are no longer officially supported by RuneScape, and you may not be able to play if using them:
    • Microsoft Windows 95
    • Microsoft Windows 98
    • Microsoft Windows ME
    • Microsoft Windows XP
    • Mac OSX 10.4
    • Mac OSX 10.5 32bit
  2. Since an unannounced update on January 2020, it is no longer possible to play Old School RuneScape on a web browser which supports NPAPI.

References[edit | edit source]

  1. Minimum requirements.
  2. Recommended Specifications and Other Requirements
  3. Go here to install